Issues loading Support Hub

Incident
May 11, 8:08pm +0 CDT

Issues loading Support Hub

Status: closed
Start: May 11, 5:30pm +0 CDT
End: May 11, 8:08pm +0 CDT
Duration: 2 hours 37 minutes
Affected Components:
Support Hub
Update

May 11, 5:30pm +0 CDT

May 11, 5:30pm +0 CDT

Customers are unable to access our Support Hub. If you need help you can reach phone support at 888-493-2525.

Update

May 11, 5:53pm +0 CDT

May 11, 5:53pm +0 CDT

Our third party partner is still experiencing issues and our Support Hub is currently unavailable. Our support team is available by phone until 7pm Central and can be reached at 888-493-2525 if you need assistance. We will continue to post updates as we have them. 

Update

May 11, 7:02pm +0 CDT

May 11, 7:02pm +0 CDT

Our third party provider is still experiencing issues. We are monitoring their updates closely and will add new information as we have it. Our phone support is closed for the night, but our team will be available at 5am Central tomorrow morning if you need assistance. 

Resolved

May 11, 8:08pm +0 CDT

May 11, 8:08pm +0 CDT

Access to the Support Hub has been restored.