Reports of delayed mailing sends

Performance
May 18, 2:15pm

Reports of delayed mailing sends

Status: closed
Start: May 18, 1:00pm
End: May 18, 2:15pm
Duration: 1 hour 14 minutes
Affected Components:
Email Sending Email Campaigns Test Emails
Update

May 18, 1:00pm

May 18, 1:00pm

We've received reports of delayed sending for both test and regular mailings. Our engineering teams are digging in and we will update with more information as we have it.

Update

May 18, 1:38pm

May 18, 1:38pm

Our engineering teams are continuing to investigate this issue, and we will update with more information as we have it.

Update

May 18, 1:54pm

May 18, 1:54pm

Our engineering teams have pushed a fix, and we will continue to monitor our systems as our sending catches-up on these previously delayed mailings.

Resolved

May 18, 2:15pm

May 18, 2:15pm

This issue is now resolved.