Outgoing email currently delayed

Incident
June 01, 3:24pm +0 CDT

Outgoing email currently delayed

Status: closed
Start: June 01, 10:02am +0 CDT
End: June 01, 3:24pm +0 CDT
Duration: 5 hours 21 minutes
Affected Components:
Email Sending Email Campaigns Automated Mailings Test Emails
Update

June 01, 10:02am +0 CDT

June 01, 10:02am +0 CDT

Our systems team is reporting a delay in emails sending from our servers.  Emails are still going out, there is just a delay them getting out the door.  

We are working hard to identify the source of the issue and we'll send an update as we get more information.  

Check back in here or sign up for notifications for updates.

Update

June 01, 10:11am +0 CDT

June 01, 10:11am +0 CDT

Our teams have identified the cause of these delays, and our systems are continuing to catch up in processing those sends. We will continue to monitor and post updates as we receive them.

Update

June 01, 12:28pm +0 CDT

June 01, 12:28pm +0 CDT

All of our sending queues are caught up, and we're continuing to monitor their performance. We will continue to post updates as we receive them.

Resolved

June 01, 3:24pm +0 CDT

June 01, 3:24pm +0 CDT

This issue has been resolved.