10/05/2021 -- Investigating reports of delayed send times

Incident
October 05, 10:45am +0 CDT

10/05/2021 -- Investigating reports of delayed send times

Status: closed
Start: October 05, 8:53am +0 CDT
End: October 05, 10:45am +0 CDT
Duration: 1 hour 52 minutes
Affected Components:
Email Sending Email Campaigns Automated Mailings Test Emails
Update

October 05, 8:53am +0 CDT

October 05, 8:53am +0 CDT

We began getting reports of delayed sends for test emails and scheduled mailings. We are investigating now. 

Test and scheduled campaigns will send, currently on an approximately 10 minute delay. No need to re-send those mailings.

We will update as we get more information. 

Update

October 05, 9:05am +0 CDT

October 05, 9:05am +0 CDT

Our Engineering teams are working on a resolution to the sending delays we've seen. 

We are currently seeing delays of up to 1 hour. We will send out additional updates as we get them. 

Update

October 05, 9:47am +0 CDT

October 05, 9:47am +0 CDT

We are continuing to work on the issue causing delays in our sending. 

These delays are also affecting audience exports and causing delays there as well. 

We are currently seeing delays of up to 2 hours for certain mailings. 

Our Engineering teams are working on a hotfix to correct the issue. 

Update

October 05, 10:18am +0 CDT

October 05, 10:18am +0 CDT

Our Engineering teams have pushed out a fix, and we are continuing to monitor as our systems catch up.

We will also continue posting further updates as we receive them. 

Resolved

October 05, 10:45am +0 CDT

October 05, 10:45am +0 CDT

A hotfix was deployed to fix the issue that was causing delays. 

Everything that was queued in the system has been sent and there is no more bottlenecking. 

Thank you