Application time-outs

Disruption
December 08, 9:57am

Application time-outs

Status: closed
Start: December 07, 9:54am
End: December 08, 9:57am
Duration: 1 day 3 minutes
Affected Components:
Web Application Email Sending Email Campaigns Home Automated Mailings Audience Contacts and Groups Test Emails Segments Signup Form Editor Lightbox Form Editor Imports Email Editor Image and Document Libraries Landing Page Editor Response Collection Response Display Automation Workflow Editor Account Settings & Billing Exports
Update

December 07, 9:54am

December 07, 9:54am

We've received reports of the application presenting slow load times and time-outs.  We are currently investigating the issue; stay tuned for updates.

Update

December 07, 12:07pm

December 07, 12:07pm

Our teams have identified that the issue is related to a third-party service provider (AWS), and we are currently working towards a resolution. Please continue to stay tuned for updates.

Update

December 07, 5:02pm

December 07, 5:02pm

AWS services are being restored, and we're continuing to monitor the application. 

Resolved

December 08, 9:57am

December 08, 9:57am

AWS reported that their systems were restored at approximately 9:00pm CST last night. After excess caution, testing, and monitoring our systems overnight and through this morning, we're moving this incident to resolved.

  • Email sending (including scheduled mailings) may have been delayed a few minutes, but there is no need to resend.
  • Importing and Exporting also processed as expected and there isn't a need to retry those as well.
  • Response data will continue to populate in-app.


Thank you for your patience and understanding in this regard!