Emma Support Hub is Down

Incident
May 23, 10:25am +0 CDT

Emma Support Hub is Down

Status: closed
Start: May 23, 10:02am +0 CDT
End: May 23, 10:25am +0 CDT
Duration: 22 minutes
Affected Components:
Support Hub
Update

May 23, 10:02am +0 CDT

May 23, 10:02am +0 CDT

The Emma Support Hub is currently down. Currently, attempts to load the site (help.myemma.com) result in an error message.

Our teams are investigating the issue, and we'll post updates as soon as we have them. We apologize for the inconvenience!

Resolved

May 23, 10:25am +0 CDT

May 23, 10:25am +0 CDT

Issues with the Emma Support Hub loading are now resolved. The site now loads as expected.

You may need to force-refresh your browser, or clear cache and cookies, if you still experience issues with loading.