Application slowness and sending delays

System Status Update
July 28, 4:00pm +0 CDT

Application slowness and sending delays

Status: closed
Start: July 28, 1:19pm +0 CDT
End: July 28, 4:00pm +0 CDT
Duration: 2 hours 40 minutes
Affected Components:
Web Application Email Sending Email Campaigns Home Automated Mailings Audience Contacts and Groups Test Emails Segments Signup Form Editor Lightbox Form Editor Imports Email Editor Image and Document Libraries Landing Page Editor Response Collection Response Display Automation Workflow Editor Account Settings & Billing Exports
Update

July 28, 1:19pm +0 CDT

July 28, 1:19pm +0 CDT

We've received reports of the application loading slowly as well as delayed arrival of sent campaigns.  We've determined the issue is due to a third party vendor incident. We are monitoring the incident and making changes on our end to mitigate impact to our application.  Stay tuned for updates.

Update

July 28, 3:02pm +0 CDT

July 28, 3:02pm +0 CDT

Any mailings that were affected by the initial sending delays are now fully caught up, and there is no need to resend your campaigns. We are continuing to monitor our systems. Please stay tuned for further updates.

Resolved

July 28, 4:00pm +0 CDT

July 28, 4:00pm +0 CDT

After extensive monitoring on our end, and with verification from our third-party vendor that their systems are fully operational, we are marking this incident to resolved.