Issues with the Campaign Editor not loading

Incident
October 21, 3:44pm +0 CDT

Issues with the Campaign Editor not loading

Status: closed
Start: October 21, 11:48am +0 CDT
End: October 21, 3:44pm +0 CDT
Duration: 3 hours 55 minutes
Affected Components:
Web Application Email Editor
Update

October 21, 11:48am +0 CDT

October 21, 11:48am +0 CDT

We're receiving reports that our editor will not load drafts (both legacy and new editor campaigns) or allow for creating new campaigns.
 

Our teams are currently investigating the cause of the issue, and we will post an update as soon as we have more details. Thank you!

Update

October 21, 12:21pm +0 CDT

October 21, 12:21pm +0 CDT

Our teams have pushed out an update to allow the editor to load as expected now. If you experience any intermittent loading, you may need to clear your browser's cache and cookies.

Out of an abundance of caution, we will continue to monitor our app for some time. We will also provide updates as soon as possible.

Resolved

October 21, 3:44pm +0 CDT

October 21, 3:44pm +0 CDT

After extensive monitoring, we're updating this incident as fully resolved.