Issues loading the Emma Support Hub
Incident Report for Emma
Resolved
The provider we use to host the Emma Support Hub has given the official all clear on the issue that was preventing content from loading. Thanks for your patience!
Posted Nov 06, 2019 - 18:50 CST
Monitoring
A fix has been implemented by our provider, and we are monitoring the results.
Posted Nov 06, 2019 - 17:07 CST
Identified
The provider we use to host the Emma Support Hub (help.myemma.com) is experiencing issues loading content, which may also be experienced on the user end. We're monitoring the partner's status page, and we'll update here as soon as there's an all clear!

If you can't get the Support Hub to load and need to reach Emma Support by phone, please call us at (888) 493-2525
Posted Nov 06, 2019 - 13:33 CST
This incident affected: Support Hub.