Contact Support form not being displayed
Incident Report for Emma
Resolved
The issue has been resolved. Full functionality of the form has been restored!
Posted Jun 01, 2020 - 15:46 CDT
Identified
We’re experiencing intermittent loading trouble with the module used to reach out to the Emma support team. If you run into any trouble and need to reach Emma Support by phone, please call us at (888) 493-2525
Posted Jun 01, 2020 - 15:14 CDT
This incident affected: Support Hub.