Issues loading the Emma Support Hub
Incident Report for Emma
Resolved
The Emma Support Hub is again loading normally. Thanks for your patience!
Posted Feb 17, 2020 - 09:57 CST
Identified
The provider we use to host the Emma Support Hub (help.myemma.com) is experiencing slow loading of content, which may also be experienced on the user end. We're monitoring the partner's status page, and we'll update here as soon as there's an all clear!

If you can't get the Support Hub to load and need to reach Emma Support by phone, please call us at (888) 493-2525.
Posted Feb 17, 2020 - 09:18 CST
This incident affected: Support Hub.