Reports of problem opening mailings
Incident Report for Emma
Resolved
This incident has been resolved.
Posted Dec 09, 2019 - 15:51 CST
Investigating
We have just started receiving reports of issues opening campaigns. Our systems team is all hands on deck to identify the problem, and we'll continue to update here.
Posted Dec 09, 2019 - 15:31 CST
This incident affected: Web Application (Email Editor).