Reports of privacy warnings and trouble with links
Incident Report for Emma
Resolved
The link issues some users experienced this morning are now resolved. Thank you!
Posted Apr 10, 2020 - 08:03 CDT
Investigating
We have just started receiving reports of issues with links in mailings this morning. Our team is actively digging in, and we'll continue to update here. Thanks!
Posted Apr 10, 2020 - 07:54 CDT
This incident affected: Web Application (Email Editor).