Errors loading campaigns.
Incident Report for Emma
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 15:36 CDT
Identified
We've identified an issue where some customers are experiencing an error opening draft emails. We've identified the issue and are deploying a fix.
Posted Jun 16, 2020 - 15:18 CDT
This incident affected: Web Application (Email Editor).